summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-22 21:46:56 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:54 +0000
commit4522e1f0c17205cc2cf35a41ba70537fbbaf48f1 (patch)
tree34ba9d5f03cfc47d96893a97ae0b59fecb402401 /gnu
parent8292c0de006f63f0a295796f3343cd5baf1311a2 (diff)
downloadguix-4522e1f0c17205cc2cf35a41ba70537fbbaf48f1.tar.gz
gnu: go-github-com-emersion-go-autostart: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-emersion-go-autostart): Move
from here ...
* gnu/packages/golang-xyz.scm: .. to here.

Change-Id: Ia1a52cc0122f3a343171c698f63783265b44bed7
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm23
-rw-r--r--gnu/packages/golang.scm22
2 files changed, 23 insertions, 22 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index af6091a249..75def7f9c5 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2536,6 +2536,29 @@ O(1) for @code{Set}, @code{Get}, @code{Delete} and @code{Len}.")
         #~(modify-phases %standard-phases
             (delete 'remove-submodule)))))))
 
+(define-public go-github-com-emersion-go-autostart
+  (package
+    (name "go-github-com-emersion-go-autostart")
+    (version "0.0.0-20210130080809-00ed301c8e9a")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/emersion/go-autostart")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0cqqvbzn32xv5lknfygrx01rx2sc6pi833k7008nlk9lsfgry06v"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/emersion/go-autostart"))
+    (home-page "https://github.com/emersion/go-autostart")
+    (synopsis "Autostart library in Go")
+    (description
+     "Go-Autostart is a Go library to run a command after login.")
+    (license license:expat)))
+
 (define-public go-github-com-emersion-go-ical
   (package
     (name "go-github-com-emersion-go-ical")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 11e19786a7..02d66c14ed 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2342,28 +2342,6 @@ management interface.  It can be used to monitor and control an OpenVPN process
 running with its management port enabled.")
       (license license:expat))))
 
-(define-public go-github-com-emersion-go-autostart
-    (package
-      (name "go-github-com-emersion-go-autostart")
-      (version "0.0.0-20210130080809-00ed301c8e9a")
-      (source
-       (origin
-         (method git-fetch)
-         (uri
-          (git-reference
-           (url "https://github.com/emersion/go-autostart")
-           (commit (go-version->git-ref version))))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "0cqqvbzn32xv5lknfygrx01rx2sc6pi833k7008nlk9lsfgry06v"))))
-      (build-system go-build-system)
-      (arguments
-       `(#:import-path "github.com/emersion/go-autostart"))
-      (home-page "https://github.com/emersion/go-autostart")
-      (synopsis "Autostart library in Go")
-      (description "Go-Autostart is a Go library to run a command after login.")
-      (license license:expat)))
-
 (define-public go-github-com-dchest-siphash
   (package
     (name "go-github-com-dchest-siphash")