summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:30:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:59 +0200
commit45d47c620cf7f6604cc27578014df208977095de (patch)
treea01106887a68be8809eeb2b6d02009e2d92e8919 /gnu
parentab003b28c6e61575fc3f090374b9a67fe3d5c841 (diff)
downloadguix-45d47c620cf7f6604cc27578014df208977095de.tar.gz
gnu: Add texlive-ptptex.
* gnu/packages/tex.scm (texlive-ptptex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5d9d70f109..87435a5d65 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -25631,6 +25631,25 @@ as a result, some of the descriptions of limitations look rather quaint to
 modern eyes.")
     (license license:lppl)))
 
+(define-public texlive-ptptex
+  (package
+    (name "texlive-ptptex")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/ptptex/" "tex/latex/ptptex/")
+             (base32
+              "1f040dv31g8bdn0awa40mvhzp095glsfsxcg28cbslckbdds5k6c")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/ptptex")
+    (synopsis "Macros for @emph{Progress of Theoretical Physics}")
+    (description
+     "The distribution contains the class (which offers an option file for
+preprints), a template, and macros for writing articles in @emph{Progress of
+Theoretical Physics}.")
+    (license license:lppl)))
+
 (define-public texlive-punk
   (package
     (name "texlive-punk")