summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-10 15:18:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-10 19:27:07 +0200
commit463a59858538e2d226a7f6bd4007d02b86df3f71 (patch)
tree464c3ac1ed209bfda82fe47fff46e76896d74c67 /gnu
parent9220dee75546db999ba34a48908e07011aff1159 (diff)
downloadguix-463a59858538e2d226a7f6bd4007d02b86df3f71.tar.gz
gnu: Add python-inquirer.
* gnu/packages/machine-learning.scm (python-inquirer): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/machine-learning.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 40f399495f..5489858d3a 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -3491,6 +3491,33 @@ Actions for the Lightning suite of libraries.")
 characters and key strokes.")
     (license license:expat)))
 
+(define-public python-inquirer
+  (package
+    (name "python-inquirer")
+    (version "3.1.3")
+    ;; Pypi has no tests.
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/magmax/python-inquirer")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0kp6a0535n9ra5sk8bmb5qvhrv0fbn1zawydi0fkb7104jqcfrzc"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list python-blessed python-editor python-readchar))
+    (native-inputs
+     (list python-poetry-core python-pexpect python-pytest))
+    (home-page "https://github.com/magmax/python-inquirer")
+    (synopsis "Collection of common interactive command line user interfaces")
+    (description
+     "Inquirer should ease the process of asking end user questions, parsing,
+validating answers, managing hierarchical prompts and providing error
+feedback.")
+    (license license:expat)))
+
 (define-public python-torchmetrics
   (package
     (name "python-torchmetrics")