summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2023-09-16 12:11:41 +0200
committerChristopher Baines <mail@cbaines.net>2023-09-25 11:30:02 +0100
commit4aa2c04395ea489e874016a17ef2aff20b98cd32 (patch)
tree604155a1bb13640e2aa041ac5911263fbdfcf169 /gnu
parentbee40b70dc1c2c767747216bd6bf65e4940a75b5 (diff)
downloadguix-4aa2c04395ea489e874016a17ef2aff20b98cd32.tar.gz
gnu: freerdp: Update to 2.11.1.
* gnu/packages/rdesktop.scm (freerdp): Update to 2.11.1.
[inputs]: Add pcsc-lite.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rdesktop.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/rdesktop.scm b/gnu/packages/rdesktop.scm
index 6a13de6148..b40ac09854 100644
--- a/gnu/packages/rdesktop.scm
+++ b/gnu/packages/rdesktop.scm
@@ -55,6 +55,7 @@
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages pulseaudio)
+  #:use-module (gnu packages security-token)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages video)
@@ -95,7 +96,7 @@ to remotely control a user's Windows desktop.")
 (define-public freerdp
   (package
     (name "freerdp")
-    (version "2.10.0")
+    (version "2.11.1")
     (source
      (origin
        (method git-fetch)
@@ -104,7 +105,7 @@ to remotely control a user's Windows desktop.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0j5waq4h7l5f0vrh7wmrv6r27p537qwbg7ab8j0n0ia5p4nvgjp2"))))
+        (base32 "1mxx711phzsaa6l022xnn41dq1315y81cgxka3rxy0fg638wipn7"))))
     (build-system cmake-build-system)
     (native-inputs
      (list docbook-xml
@@ -139,6 +140,7 @@ to remotely control a user's Windows desktop.")
            openh264
            opensles
            openssl
+           pcsc-lite ; for smartcard support
            pulseaudio
            zlib))
     (propagated-inputs (list libxkbcommon openssl wayland))