summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2024-03-11 12:59:41 +0000
committerLudovic Courtès <ludo@gnu.org>2024-04-05 18:23:43 +0200
commit4af58f55d6855af97d4c6b89c695bf6fe9dfb165 (patch)
treeb2609bec17f4ee73d64a308a3068a1dc9c925e97 /gnu
parent560d5c66925970a5104a46051ae74e2dbd16adba (diff)
downloadguix-4af58f55d6855af97d4c6b89c695bf6fe9dfb165.tar.gz
gnu: atop: Update source hash.
The new ‘atop-2.9.0.tar.gz’ adds a single file, ‘mkdate’, which, when
available, generates a ‘versdate.h’ file containing the current date.

* gnu/packages/admin.scm (atop): Update source hash and add snippet.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Change-Id: I2de2068d052d0b37aff1a6d18f5639baac6ccdfa
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f464b7694d..4affcc179c 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -5122,7 +5122,12 @@ Netgear devices.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1y4qmc8i7zg2cqrmz38dxbsj8bb2h7jm1zz23gqcdygkgaymwddw"))))
+                "09prpw20ps6cd8qr63glbcip3jrvnnic0m7j1q02g8hjnw8z50ld"))
+              (snippet
+               ;; The 'mkdate' script generates a new 'versdate.h' header
+               ;; containing the build date.  That makes builds
+               ;; non-reproducible so remove it.
+               #~(delete-file "mkdate"))))
     (build-system gnu-build-system)
     (arguments
      (list