summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-23 13:19:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-23 13:36:47 +0100
commit561d429aa4d4cb5c4cc2963631c274f7de474973 (patch)
treedbecec3d7ee7f6705df55caa8be9fcea6817cc69 /gnu
parenta6b6d1bd6a25a1a2e4e3e2113b8b1fda33e18ab4 (diff)
downloadguix-561d429aa4d4cb5c4cc2963631c274f7de474973.tar.gz
gnu: python-nose2: Update to 0.14.0.
* gnu/packages/check.scm (python-nose2): Update to 0.14.0.
[native-inputs]: Remove python-coverage.
[propagated-inputs]: Remove python-six.

Change-Id: I15a30723fe49cca9929524e543d12c9e2f4b02ca
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 4de5b1c0d4..a7ba16574f 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1227,14 +1227,14 @@ available via the @code{unittest.mock} module.")
 (define-public python-nose2
   (package
     (name "python-nose2")
-    (version "0.11.0")
+    (version "0.14.0")
       (source
         (origin
           (method url-fetch)
           (uri (pypi-uri "nose2" version))
           (sha256
            (base32
-            "1scxwvwbgfdj41acma41xzdhcfdwjj9irj6sfifdbyf9dryqs83d"))))
+            "1936fkrxg672bhp9i32ivna7jbydl9dpbhyn5f3059xrl1qdfa2w"))))
     (build-system python-build-system)
     (arguments
      (list #:phases
@@ -1245,10 +1245,6 @@ available via the @code{unittest.mock} module.")
                      ;; Tests require nose2 itself.
                      (setenv "PYTHONPATH" (getcwd))
                      (invoke (string-append #$output "/bin/nose2") "-v")))))))
-    (native-inputs
-     (list python-coverage))
-    (propagated-inputs
-     (list python-six))
     (home-page "https://github.com/nose-devs/nose2")
     (synopsis "Next generation of nicer testing for Python")
     (description