summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-03-05 01:19:34 +0800
committerLudovic Courtès <ludo@gnu.org>2024-03-06 23:25:51 +0100
commit5980c8a6b16dd589769ad7cd0bab82fcb9c116cb (patch)
tree43b1f945e0ae7b9cf527ee3b50e7209dbc919afd /gnu
parent01f685d56016ae529381a73daedccc1949b808ec (diff)
downloadguix-5980c8a6b16dd589769ad7cd0bab82fcb9c116cb.tar.gz
gnu: libtheora: Use Gexps.
* gnu/packages/xiph.scm (libtheora): Use Gexps.

Change-Id: Ie055cd4f6cb9d2a4601b93d1f9db227598349c7c
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xiph.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index b47c718fb6..879d8e8d39 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -13,6 +13,7 @@
 ;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -47,7 +48,8 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (guix gexp))
 
 (define-public libogg
   (package
@@ -115,7 +117,7 @@ polyphonic) audio and music at fixed and variable bitrates from 16 to
              (patches (search-patches "libtheora-config-guess.patch"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:configure-flags '("--disable-static")))
+     (list #:configure-flags #~'("--disable-static")))
     (inputs (list libvorbis))
     ;; The .pc files refer to libogg.
     (propagated-inputs (list libogg))