summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 14:36:03 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:58:42 +0100
commit5a5b8885b943c0ba24e21839c3ec89b160b3b125 (patch)
treec59759436e3816ae3e1419a1a3c70c937a8ab185 /gnu
parent5f578c37429edc0e6c50f40cb1fb2467eba49e5d (diff)
downloadguix-5a5b8885b943c0ba24e21839c3ec89b160b3b125.tar.gz
gnu: go-github-com-pbnjay-memory: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-pbnjay-memory): Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: Ie46dfc76fd468ab3a5af886592a150e3e4565111
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/golang.scm26
2 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 3bdd43edc6..73a7188c17 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2654,6 +2654,33 @@ comparison library, to Go.  Both a library and a command-line tool are
 included in this package.")
     (license license:expat)))
 
+(define-public go-github-com-pbnjay-memory
+  (let ((commit "974d429e7ae40c89e7dcd41cfcc22a0bfbe42510")
+        (revision "1"))
+    (package
+      (name "go-github-com-pbnjay-memory")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/pbnjay/memory")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0kazg5psdn90pqadrzma5chdwh0l2by9z31sspr47gx93fhjmkkq"))))
+      (build-system go-build-system)
+      (arguments
+       (list
+        #:import-path "github.com/pbnjay/memory"))
+      (home-page "https://github.com/gedex/inflector")
+      (synopsis "Go library to report total system memory")
+      (description
+       "@code{memory} provides a single method reporting total physical system
+memory accessible to the kernel.  It does not account for memory used by other
+processes.")
+      (license license:bsd-3))))
+
 (define-public go-github-com-pierrec-cmdflag
   (package
     (name "go-github-com-pierrec-cmdflag")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d5b8a67b97..445ca0097b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6681,32 +6681,6 @@ and no external C (cgo) code is used, which should make the library very eas
 to use.")
     (license license:expat)))
 
-(define-public go-github-com-pbnjay-memory
-  (let ((commit "974d429e7ae40c89e7dcd41cfcc22a0bfbe42510")
-        (revision "1"))
-    (package
-      (name "go-github-com-pbnjay-memory")
-      (version (git-version "0.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                       (url "https://github.com/pbnjay/memory")
-                       (commit commit)))
-                (file-name (string-append "go-github-com-pbnjay-memory-"
-                                          version "-checkout"))
-                (sha256
-                 (base32
-                  "0kazg5psdn90pqadrzma5chdwh0l2by9z31sspr47gx93fhjmkkq"))))
-      (build-system go-build-system)
-      (arguments
-       `(#:import-path "github.com/pbnjay/memory"))
-      (home-page "https://github.com/gedex/inflector")
-      (synopsis "Go library to report total system memory")
-      (description "@code{memory} provides a single method reporting total
-physical system memory accessible to the kernel.  It does not account for memory
-used by other processes.")
-      (license license:bsd-3))))
-
 (define-public go-github-com-surge-glog
   (let ((commit "2578deb2b95c665e6b1ebabf304ce2085c9e1985")
         (revision "1"))