summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-15 23:43:58 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-15 23:43:58 +0000
commit5b59c149e018e880f76407ec61df8d20ac063ece (patch)
tree75dcdf6a9e9319a10be78e7efbd008202a41f205 /gnu
parent47f2a8c14ba40c825360a6d52d602dbbf4bbff44 (diff)
downloadguix-5b59c149e018e880f76407ec61df8d20ac063ece.tar.gz
gnu: go-github-com-beorn7-perks-quantile: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-beorn7-perks-quantile): Move
from here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: I09a2080b78fd3273af75cbbbb49718bb8eec86e5
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm25
-rw-r--r--gnu/packages/syncthing.scm25
2 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 2b0aa97f99..ef700b9373 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -237,6 +237,31 @@ interface around the standard library's @code{time} package so that the applicat
 can use the realtime clock while tests can use the mock clock.")
     (license license:expat)))
 
+(define-public go-github-com-beorn7-perks-quantile
+  (package
+    (name "go-github-com-beorn7-perks-quantile")
+    (version "1.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/beorn7/perks")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "17n4yygjxa6p499dj3yaqzfww2g7528165cl13haj97hlx94dgl7"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/beorn7/perks/quantile"
+           #:unpack-path "github.com/beorn7/perks"))
+    (home-page "https://github.com/beorn7/perks")
+    (synopsis "Compute approximate quantiles over an unbounded data stream")
+    (description
+     "Perks contains the Go package @code{quantile} that computes
+approximate quantiles over an unbounded data stream within low memory and CPU
+bounds.")
+    (license license:expat)))
+
 (define-public go-github-com-bitly-go-hostpool
   (package
     (name "go-github-com-bitly-go-hostpool")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 472b49f245..ebbf8b82bb 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -708,31 +708,6 @@ notification library in Go.")
       (home-page "https://github.com/syncthing/notify")
       (license expat))))
 
-(define-public go-github-com-beorn7-perks-quantile
-  (package
-    (name "go-github-com-beorn7-perks-quantile")
-    (version "1.0.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/beorn7/perks")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "17n4yygjxa6p499dj3yaqzfww2g7528165cl13haj97hlx94dgl7"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/beorn7/perks/quantile"
-       #:unpack-path "github.com/beorn7/perks"))
-    (synopsis "Compute approximate quantiles over an unbounded data stream")
-    (description
-     "Perks contains the Go package @code{quantile} that computes
-approximate quantiles over an unbounded data stream within low memory and CPU
-bounds.")
-    (home-page "https://github.com/beorn7/perks")
-    (license expat)))
-
 (define-public go-github-com-matttproud-golang-protobuf-extensions-pbutil
   (let ((commit "c12348ce28de40eed0136aa2b644d0ee0650e56c")
         (revision "0"))