summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-02-19 00:16:47 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-02-21 12:05:00 -0500
commit5e66832ad47a2f4222ccf681c39266cfc9fc1f15 (patch)
tree5602c45a9c622ccf04db7e43362cf3472aa1a2c9 /gnu
parentec6d6a51a3ad4c3c0fe90cec1569e29a602d62e2 (diff)
downloadguix-5e66832ad47a2f4222ccf681c39266cfc9fc1f15.tar.gz
gnu: mold: Update to 2.4.0.
* gnu/packages/mold.scm (mold): Update to 2.4.0.
[source]: Streamline snippet.
[inputs]: Remove unused openssl input.

Change-Id: Iba4e7c1053459c5e765eb7089428149b49151e29
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mold.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/mold.scm b/gnu/packages/mold.scm
index 4ce3741be2..8625efff27 100644
--- a/gnu/packages/mold.scm
+++ b/gnu/packages/mold.scm
@@ -35,7 +35,7 @@
 (define-public mold
   (package
     (name "mold")
-    (version "2.3.2")
+    (version "2.4.0")
     (source
      (origin
        (method git-fetch)
@@ -44,22 +44,10 @@
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1p6w92caysy9h0vkl26iv3viv0lvwzvbd357yykls0p13hnzlzkr"))
+        (base32 "0rqw7p61qijxhbfm887xbh8idbp5w30axvwgmm68s03xirnr7ymr"))
        (modules '((guix build utils)))
        (snippet
         #~(begin
-            ;; Fix detection of i686 systems.
-            ;; This can be removed with the next release of mold.
-            (substitute* "test/elf/common.inc"
-              (("echo i386") "echo i686"))
-            (substitute* '("test/elf/common.inc"
-                           "test/elf/global-offset-table.sh"
-                           "test/elf/i386_tls-module-base.sh"
-                           "test/elf/large-alignment-dso.sh"
-                           "test/elf/large-alignment.sh"
-                           "test/elf/nocopyreloc.sh"
-                           "test/elf/range-extension-thunk.sh")
-              (("MACHINE = i386") "MACHINE = i686"))
             (for-each
              (lambda (x)
                (delete-file-recursively (string-append "third-party/" x)))
@@ -93,7 +81,7 @@
               ;; but compiler in Guix will insert the path of gcc-lib and
               ;; glibc into the output binary.
               (delete-file "test/elf/rpath.sh"))))))
-    (inputs (list mimalloc openssl tbb xxhash zlib `(,zstd "lib")))
+    (inputs (list mimalloc tbb xxhash zlib `(,zstd "lib")))
     (home-page "https://github.com/rui314/mold")
     (synopsis "Fast linker")
     (description