summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-10 01:20:42 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-10 01:52:26 +0100
commit5edc86820f3f5b056662a0674af93ffbef097afe (patch)
tree5da9a56e5e0d97e1262ea49ba8693423f38201a7 /gnu
parent57b05e4a24a03636f6d964ef051d1c3a34b7bc6e (diff)
downloadguix-5edc86820f3f5b056662a0674af93ffbef097afe.tar.gz
gnu: yoshimi: Find ncurses with pkg-config.
* gnu/packages/music.scm (yoshimi)[arguments]: Remove obsolete
‘find-ncurses’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 420f6ca121..00a0102bd6 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1992,17 +1992,7 @@ capabilities, custom envelopes, effects, etc.")
               (("-msse -msse2 -mfpmath=sse") "")
               (("-march=(athlon64|core2)" flag)
                (string-append flag " -msse -msse2 -mfpmath=sse")))
-            #t))
-         ;; Yoshimi tries to find ncurses with pkg-config, but our ncurses
-         ;; package does not install .pc files.
-         (add-after 'unpack 'find-ncurses
-           (lambda _
-             (substitute* "src/CMakeLists.txt"
-               (("LIBNCURSES REQUIRED") "LIBNCURSES")
-               (("NCURSES REQUIRED") "NCURSES")
-               (("FATAL_ERROR \"libncurses") "STATUS \"libncurses")
-               (("\\$\\{NCURSES_LIBRARIES\\}") "ncurses"))
-             #t)))))
+            #t)))))
     (inputs
      `(("boost" ,boost)
        ("fftwf" ,fftwf)