summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 12:52:36 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:35:21 +0100
commit5eea7f6597774ca4c92ef74f9e1c7fb51f45a35f (patch)
tree07d6d478ee3f0f798a1f7058eaf2983fdf335678 /gnu
parenteef9ae4dbf98dfa1b667a2ccb455d7beae1a3b58 (diff)
downloadguix-5eea7f6597774ca4c92ef74f9e1c7fb51f45a35f.tar.gz
gnu: Add go-github-com-gxed-hashland-murmur3.
* gnu/packages/golang-crypto.scm (go-github-com-gxed-hashland-murmur3): New variable.

Change-Id: I9085a373fa298d3359d164768a613a7a56c948db
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-crypto.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 4f90ab4242..24e114166c 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -555,6 +555,20 @@ libraries.")
 hash algorithm.  See http://keccak.noekeon.org.")
       (license license:expat))))
 
+(define-public go-github-com-gxed-hashland-murmur3
+  (package
+    (inherit go-github-com-gxed-hashland)
+    (name "go-github-com-gxed-hashland-murmur3")
+    (arguments
+     (list
+      #:import-path "github.com/gxed/hashland/murmur3"
+      #:unpack-path "github.com/gxed/hashland"))
+    (synopsis "Golang implementation of MurmurHash3 algorithm")
+    (description
+     "This package provides a native Go implementation of
+@url{https://en.wikipedia.org/wiki/MurmurHash, Austin Appleby's third
+MurmurHash} revision (aka MurmurHash3).")))
+
 (define-public go-github-com-jcmturner-aescts-v2
   (package
     (name "go-github-com-jcmturner-aescts-v2")