summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 14:52:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 14:55:12 +0100
commit6236ae32aab98e62d4b3c00c979e6c87108d9220 (patch)
tree89bfa37e50ea0d4f158fa62b1929cfebd78108b8 /gnu
parentff1bb647b5d66af5fb1fbacdea08b46a6db90e77 (diff)
downloadguix-6236ae32aab98e62d4b3c00c979e6c87108d9220.tar.gz
gnu: Add go-github-com-facebookgo-atomicfile.
* gnu/packages/golang-xyz.scm (go-github-com-facebookgo-atomicfile): New
variable.

Change-Id: Ib6c685b5fa2b42ef0fe057e24547c1244ed449a4
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 66ec8ae39f..56cf1d0287 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1772,6 +1772,41 @@ designed to deliver dynamic configurations with unparalleled accuracy, safety,
 and speed.")
     (license license:expat)))
 
+(define-public go-github-com-facebookgo-atomicfile
+  (package
+    (name "go-github-com-facebookgo-atomicfile")
+    (version "0.0.0-20151019160806-2de1f203e7d5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/facebookarchive/atomicfile")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1vsx6r6y601jxvjqc8msbpr5v1037dfxxdd8h1q3s8wm6xhvj2v6"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/facebookgo/atomicfile"))
+    (home-page "https://github.com/facebookgo/atomicfile")
+    (synopsis "Atomically written/replaced file")
+    (description
+     "Package atomicfile provides the ability to write a file with an eventual
+rename on Close (using @code{os.Rename}).  This allows for a file to always be
+in a consistent state and never represent an in-progress write.")
+    ;; patents
+    ;;
+    ;; Additional Grant of Patent Rights Version 2
+    ;; <...>
+    ;; Facebook, Inc. ("Facebook") hereby grants to each recipient of the
+    ;; Software ("you") a perpetual, worldwide, royalty-free, non-exclusive,
+    ;; irrevocable (subject to the termination provision below) license under
+    ;; any Necessary Claims, to make, have made, use, sell, offer to sell,
+    ;; import, and otherwise transfer the Software.
+    ;; <...>
+    (license license:bsd-3)))
+
 (define-public go-github-com-facette-natsort
   (package
     (name "go-github-com-facette-natsort")