summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:34:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:02 +0200
commit6357a12f55c3670d6370cae30091fd360a22835d (patch)
tree8e1e5188ad51f128023c2400ab86dcce9c46545f /gnu
parentfe6cf52500a014033a2b7b0b1512a81c9136de59 (diff)
downloadguix-6357a12f55c3670d6370cae30091fd360a22835d.tar.gz
gnu: Add texlive-naive-ebnf.
* gnu/packages/tex.scm (texlive-naive-ebnf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4d93a36031..131aed76de 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4991,6 +4991,31 @@ related to multiobjective optimisation, multiobjective evolutionary
 algorithms, multicriteria decision making and similar fields.")
     (license license:lppl)))
 
+(define-public texlive-naive-ebnf
+  (package
+    (name "texlive-naive-ebnf")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/naive-ebnf/"
+                   "source/latex/naive-ebnf/"
+                   "tex/latex/naive-ebnf/")
+             (base32
+              "0fi04awwvizb2p4lp90wl7syingnc7fwrhzwd20x82a9v89iy6pf")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-filecontentsdef
+           texlive-l3kernel
+           texlive-pgfopts))
+    (home-page "https://ctan.org/pkg/naive-ebnf")
+    (synopsis "EBNF in Plain Text")
+    (description
+     "With the help of this LaTeX package, a context-free grammar (CFG) may be
+rendered in a plain-text mode using a simplified Extended Backus-Naur
+Form (EBNF) notation.")
+    (license license:expat)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")