summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-11-25 04:52:01 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-05 21:35:13 +0100
commit648db3ad2bee9499bed1b7725eca2c2a4aaebe81 (patch)
tree90c3c139cd8bf46c5355c272ac5b78263873594d /gnu
parent6a8d2499ae7af242a71e1f215dd4a5038b5e48eb (diff)
downloadguix-648db3ad2bee9499bed1b7725eca2c2a4aaebe81.tar.gz
gnu: Add litterbox.
* gnu/packages/irc.scm (litterbox): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/irc.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 2817624437..840c27f5c5 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -571,6 +571,39 @@ interface for those who are accustomed to the ircII way of doing things.")
                    ;; distribute binaries.
                    (license:non-copyleft "http://epicsol.org/copyright")))))
 
+(define-public litterbox
+  (package
+    (name "litterbox")
+    (version "1.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://git.causal.agency/litterbox/snapshot/litterbox-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "0ll5d18slngdg2qhaxkvrcq2p1admh0h7sr06wx8347ka0vvrgjl"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; There are no tests.
+       #:make-flags
+       (list
+        (string-append "CC=" ,(cc-for-target))
+        (string-append "PREFIX=" %output))))
+    (native-inputs
+      `(("pkg-config" ,pkg-config)
+        ("universal-ctags" ,universal-ctags)))
+    (inputs
+      `(("libressl" ,libressl)
+        ("sqlite" ,sqlite)))
+    (home-page "https://code.causal.agency/june/litterbox")
+    (synopsis "TLS-only IRC logger")
+    (description
+"@command{litterbox} is a TLS-only IRC logger.  It logs
+events from IRC in a SQLite database, indexing messages for full-text
+search.  It is intended for use with the IRC bouncer @command{pounce},
+but can also be used independently as a logging bot.")
+    (license license:gpl3+)))
+
 (define-public inspircd
   (package
     (name "inspircd")