summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-29 16:01:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-12 20:55:47 -0400
commit667f09218be9347b53a1c7293221a3689275c6a1 (patch)
tree2919c5cc76b28823c8c4a57fa5f06a33cd817426 /gnu
parent9539408e9151f061efd1fd4687a5842daec1c1cf (diff)
downloadguix-667f09218be9347b53a1c7293221a3689275c6a1.tar.gz
gnu: Add gsettings-desktop-schemas-next.
* gnu/packages/gnome.scm (gsettings-desktop-schemas-next): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6aeda7a7f1..41d84e2fba 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2651,6 +2651,21 @@ on the GNOME Desktop with a single simple application.")
 schemas for settings shared by various components of the GNOME desktop.")
     (license license:lgpl2.1+)))
 
+(define-public gsettings-desktop-schemas-next
+  (package
+    (inherit gsettings-desktop-schemas)
+    (name "gsettings-desktop-schemas-next") ;to avoid propagation conflicts
+    (version "42.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://gnome/sources/" name "/"
+                           (version-major version)  "/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "1li3fcqwnw20f4j0i21i88fygm0hli8gmzkn4apgf8ynkrd371k6"))))))
+
 (define-public python-liblarch
   (package
     (name "python-liblarch")