summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:51 +0200
commit691314404550e67c567cb9fa309e0a8314ccd7ce (patch)
tree0c9de0a8a683a70bec5f409c12cdf161750ff3db /gnu
parent78e8b9b34d4cc173e2617ad5daa3b1c19d87e400 (diff)
downloadguix-691314404550e67c567cb9fa309e0a8314ccd7ce.tar.gz
gnu: Add texlive-texsurgery.
* gnu/packages/tex.scm (texlive-texsurgery): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d39652f19d..ea7093e37f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -97880,6 +97880,28 @@ styles, labels, legends; it even allows the user to define completely new
 shading modes.")
     (license license:gpl2)))
 
+(define-public texlive-texsurgery
+  (package
+    (name "texlive-texsurgery")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/texsurgery/"
+                   "tex/latex/texsurgery/")
+             (base32
+              "042jafcsvsjijmmmi8vz417178rbb02vk7vwd16b4laxxpzd5b2a")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/texsurgery")
+    (synopsis "LaTeX companion to the @code{texsurgery} Python project")
+    (description
+     "This LaTeX library is a companion to the @code{texsurgery} Python project.
+It will make sure that @samp{pdflatex document.tex} will work, with reasonable
+defaults, for a document that is intended to work with @code{texsurgery}, and
+also has other uses, always in tandem with the @code{texsurgery} Pypi
+package.")
+    (license license:bsd-3)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar