summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-01-21 01:14:22 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-21 01:14:22 +0100
commit6915da225fc7fb6b7a2920a40f542f4d91591a5d (patch)
tree77a94e6c1a122f9aeabaeb51ed0f7c494805e6d2 /gnu
parentd0e9ded713e06790aad4992de7c26d075d18b86d (diff)
downloadguix-6915da225fc7fb6b7a2920a40f542f4d91591a5d.tar.gz
gnu: gnome-keyring: Fix build with Automake 1.15.1.
* gnu/packages/gnome.scm (gnome-keyring)[arguments] <fix-docbook>:
Invoke autoconf/aclocal/automake.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ed9e167cf5..8ddc022546 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -686,7 +686,15 @@ GNOME Desktop.")
                               "/manpages/docbook.xsl")))
             (setenv "XML_CATALOG_FILES"
                     (string-append (assoc-ref inputs "docbook-xml")
-                                   "/xml/dtd/docbook/catalog.xml")))))))
+                                   "/xml/dtd/docbook/catalog.xml"))
+
+            ;; Rerun the whole thing to avoid version mismatch ("This is
+            ;; Automake 1.15.1, but the definition used by this
+            ;; AM_INIT_AUTOMAKE comes from Automake 1.15.").  Note: we don't
+            ;; use 'autoreconf' because it insists on running 'libtoolize'.
+            (invoke "autoconf")
+            (invoke "aclocal")
+            (invoke "automake" "-ac"))))))
     (inputs
      `(("libgcrypt" ,libgcrypt)
        ("linux-pam" ,linux-pam)