summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 11:31:23 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:45 +0100
commit702d01a5960464f32b1f8b185322ec5a4903464d (patch)
treebbf90949aa8485468dae389c11d01648e5a1d221 /gnu
parent0c1f85084a80de0685ec59ff6f2ac07f85c18338 (diff)
downloadguix-702d01a5960464f32b1f8b185322ec5a4903464d.tar.gz
gnu: tz: Refresh package style.
* gnu/packages/time.scm (tz): [arguments]: Swap to list
style. <#:phases>: Swap to default 'check phase. Set <#:install-source?>
to #t.
[inputs]: Remove labels.
[description]: Fix indentation.

Change-Id: Id375585c926535015f5c4b8b9964fa455de7ca41
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/time.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 101776fa56..b74d1bc092 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -23,6 +23,7 @@
 ;;; Copyright © 2022 Pradana AUMARS <paumars@courrier.dev>
 ;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2024 Liliana Marie Prikler <liliana.prikler@gmail.com>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -642,23 +643,20 @@ calls.")
         (base32 "1zf5w6338y0s0pf0jlpbqzlbxbx39s93z0bmdaa0cxkxs8cz8xij"))))
     (build-system go-build-system)
     (arguments
-     `(#:go ,go-1.17
-       #:import-path "github.com/oz/tz"
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key import-path tests? #:allow-other-keys)
-             (when tests?
-               (invoke "go" "test" "-cover" import-path)))))))
+     (list
+      #:go go-1.17
+      #:install-source? #f
+      #:import-path "github.com/oz/tz"))
     (inputs
-     `(("github.com/charmbracelet/bubbletea" ,go-github-com-charmbracelet-bubbletea)
-       ("github.com/tkuchiki/go-timezone" ,go-github-com-tkuchiki-go-timezone)
-       ("github.com/muesli/termenv" ,go-github-com-muesli-termenv)))
+     (list go-github-com-charmbracelet-bubbletea
+           go-github-com-muesli-termenv
+           go-github-com-tkuchiki-go-timezone))
     (home-page "https://github.com/oz/tz")
     (synopsis "TUI time zone helper")
     (description
-"@command{tz} helps you schedule things across time zones.  It is an interactive
-TUI program that displays time across a few time zones of your choosing.")
+     "@command{tz} helps you schedule things across time zones.  It is an
+interactive TUI program that displays time across a few time zones of your
+choosing.")
     (license gpl3+)))
 
 (define-public countdown