summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-07-12 16:56:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-07-12 17:39:57 +0300
commit706af6dfd7e1a744768d5ec613f8765c0c6d0b6f (patch)
tree2c1364fa17932274a93b68de98d6ed1e7ad29646 /gnu
parent321bb9f0e90140da6a7b064ce3892b261a494ece (diff)
downloadguix-706af6dfd7e1a744768d5ec613f8765c0c6d0b6f.tar.gz
gnu: numactl: Fix building on riscv64-linux.
* gnu/packages/linux.scm (numactl)[arguments]: When building for
riscv64-linux always link with libatomic.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index efd0d09ad1..f9ec702c23 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3537,7 +3537,10 @@ compressed, transparent to other programs, without decompressing them.")
                 "1xngddsph43bxljywahi9d44fxr022slsap4hh91w8xnq54d2sw2"))))
     (build-system gnu-build-system)
     (arguments
-     '(;; There's a 'test' target, but it requires NUMA support in the kernel
+     `(,@(if (target-riscv64?)
+           `(#:make-flags (list "LDFLAGS=-latomic"))
+           '())
+       ;; There's a 'test' target, but it requires NUMA support in the kernel
        ;; to run, which we can't assume to have.
        #:tests? #f))