summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-12 08:45:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-09-12 11:26:05 +0300
commit73158a5f6299a07a1581f0f33c5e86be660f6270 (patch)
treeb9f6220377ab860aeb645e616732cfabc6745811 /gnu
parentf5449685143be0805a8a9b54ddecee94e368c6e9 (diff)
downloadguix-73158a5f6299a07a1581f0f33c5e86be660f6270.tar.gz
gnu: python-scikit-build: Skip more network tests.
* gnu/packages/python-xyz.scm (python-scikit-build)[arguments]: Add a
phase to mark more network tests as isolated to easily skip them.

Change-Id: I2f955182f411a68550fbd3c356bfda5584091428
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9dd963e396..b350c61963 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -33505,6 +33505,13 @@ and frame grabber interface.")
                 (("^(CMAKE_DEFAULT_EXECUTABLE = ).*" _ head)
                  (format #f "~a ~s~%" head
                          (search-input-file inputs "bin/cmake"))))))
+          (add-before 'check 'pre-check
+            (lambda _
+              ;; Some tests try to access the network before being skipped.
+              ;; Skip them by default.
+              (substitute* "tests/test_setup.py"
+                (("pytest\\.mark\\.skipif\\(not is_site_reachable.*")
+                 "pytest.mark.isolated()\n"))))
           (replace 'check
             (lambda* (#:key tests? #:allow-other-keys)
               (when tests?