summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-10 04:35:25 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:20 +0800
commit73c8574314295f32faa5424bc4623442d73e8444 (patch)
tree8d776bf1daca413c56f8021c5327d29404ac640f /gnu
parent8e9a2932d6827243a8df87df462b87800b1a23e9 (diff)
downloadguix-73c8574314295f32faa5424bc4623442d73e8444.tar.gz
gnu: python-bleach: Update to 6.0.0.
* gnu/packages/python-xyz.scm (python-bleach): Update to 6.0.0.
[propagated-inputs]: Remove PYTHON-WEBENCODINGS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 03f40ab806..e800baa482 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15117,13 +15117,13 @@ systems, as a command line tool, and as a Python library.")
 (define-public python-bleach
   (package
     (name "python-bleach")
-    (version "5.0.1")
+    (version "6.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "bleach" version))
        (sha256
-        (base32 "0p089853pkwzf1j2zjlmw67pwbkk0whpzfx9dbrd56zb8xf2a0qd"))
+        (base32 "054lp46iymchq3np0nar3k2h4da3wq4rzw652kdxh1syb70qa6hs"))
        (snippet
         #~(begin
             (use-modules (guix build utils))
@@ -15131,7 +15131,7 @@ systems, as a command line tool, and as a Python library.")
               (("bleach\\._vendor\\.html5lib") "html5lib"))
             (delete-file-recursively "bleach/_vendor/html5lib")))))
     (build-system pyproject-build-system)
-    (propagated-inputs (list python-html5lib python-tinycss2 python-webencodings))
+    (propagated-inputs (list python-html5lib python-tinycss2))
     (native-inputs (list python-pytest))
     (home-page "https://github.com/mozilla/bleach")
     (synopsis "Whitelist-based HTML-sanitizing tool")