summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-06 01:33:48 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-06 01:35:27 +0800
commit780fdb61f6dd06a7cdc410504b0cf9b8650fd642 (patch)
treeab0d528641ddf77132d0084e75b7cac2dd961cb2 /gnu
parent05da43104c37dfa548559d4d43a54c3083be2e86 (diff)
downloadguix-780fdb61f6dd06a7cdc410504b0cf9b8650fd642.tar.gz
gnu: lsof: Use G-expressions.
* gnu/packages/lsof.scm (lsof)[arguments]: Use G-expressions.

Change-Id: Id086d46c5dbef6028e5eae4df1d2f0b24d4c3d76
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lsof.scm36
1 files changed, 19 insertions, 17 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index f3f808ad90..7d849c80b5 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -25,6 +25,7 @@
   #:use-module (guix packages)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix gexp)
   #:use-module (guix utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
@@ -56,23 +57,24 @@
                          procps ;for ps
                          util-linux)) ;for unshare
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'fix-configure-ac-version
-                    ;; see https://github.com/lsof-org/lsof/commit/932a0b3b1992497e23fd9b8d31116b9ca9b0f98d
-                    ;; to fix tests/case-01-version.bash test fail.
-                    (lambda _
-                      (substitute* "configure.ac"
-                        (("4\\.99\\.0")
-                         "4.99.3"))))
-                  (add-before 'bootstrap 'disable-failing-tests
-                    (lambda _
-                      (substitute* "Makefile.am"
-                        ;; Fails with ‘ERROR!!! client gethostbyaddr() failure’.
-                        (("(TESTS \\+=.*) tests/LTsock" _ prefix)
-                         prefix)
-                        ;; Fails because /proc not mounted in sandbox
-                        (("\tdialects/linux/tests/case-20-epoll.bash \\\\")
-                         "\\")))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'fix-configure-ac-version
+                 ;; see https://github.com/lsof-org/lsof/commit/932a0b3b1992497e23fd9b8d31116b9ca9b0f98d
+                 ;; to fix tests/case-01-version.bash test fail.
+                 (lambda _
+                   (substitute* "configure.ac"
+                     (("4\\.99\\.0")
+                      "4.99.3"))))
+               (add-before 'bootstrap 'disable-failing-tests
+                 (lambda _
+                   (substitute* "Makefile.am"
+                     ;; Fails with ‘ERROR!!! client gethostbyaddr() failure’.
+                     (("(TESTS \\+=.*) tests/LTsock" _ prefix)
+                      prefix)
+                     ;; Fails because /proc not mounted in sandbox
+                     (("\tdialects/linux/tests/case-20-epoll.bash \\\\")
+                      "\\")))))))
     (synopsis "Display information about open files")
     (description
      "Lsof stands for LiSt Open Files, and it does just that.