summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-15 22:31:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-15 23:06:15 +0100
commit7a2d1287795318d40850949c88679fcbb4f78b4b (patch)
tree4b678eb7ebdfb5ee1096d18210b60b7bfafc4222 /gnu
parent19db1551dc6f6180d2cda9084c2dec37bf4923c9 (diff)
downloadguix-7a2d1287795318d40850949c88679fcbb4f78b4b.tar.gz
gnu: Add python-namex.
* gnu/packages/python-xyz.scm (python-namex): New variable.

Change-Id: I02d4ed5e426f0b432c27086aa90628ae54759ca2
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1ca5d7f8fd..f224ab4eb8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21104,6 +21104,26 @@ JSON) codec.")
      ;; number of files with other licenses.
      (list license:gpl2+ license:asl2.0 license:lgpl2.1+ license:cc-by-sa3.0))))
 
+(define-public python-namex
+  (package
+    (name "python-namex")
+    (version "0.0.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "namex" version))
+       (sha256
+        (base32 "16ynrq245c3nywv476izrc4bcacm9gxjzgr67ng91g929ny6bfl4"))))
+    (build-system pyproject-build-system)
+    (arguments (list #:tests? #false))  ;there are none
+    (home-page "https://github.com/fchollet/namex")
+    (synopsis
+     "Separate implementation and public API surface of Python packages")
+    (description
+     "This package provides a simple utility to separate the
+implementation of your Python package and its public API surface.")
+    (license license:asl2.0)))
+
 (define-public python-natsort
   (package
     (name "python-natsort")