summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-21 11:44:48 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:44 -0500
commit7aa7d85bac2b4e1e94e0a4b3682f94f275e31c75 (patch)
treedc32c33fee67c86330dc7c23d6e76e8d811f2e5b /gnu
parent00e4bd25006411dfe6f98d4b237aec4581f95667 (diff)
downloadguix-7aa7d85bac2b4e1e94e0a4b3682f94f275e31c75.tar.gz
gnu: webkitgtk: Enable GStreamer GL support.
* gnu/packages/webkit.scm (webkitgtk)[configure-flags]: Remove the
'-DUSE_GSTREAMER_GL=OFF' build option.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/webkit.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 44a0de33c2..cfe24f41b0 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -251,15 +251,7 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
                           "-DUSE_SYSTEMD=OFF"
                           (string-append ; uses lib64 by default
                            "-DLIB_INSTALL_DIR="
-                           (assoc-ref %outputs "out") "/lib")
-                          ;; XXX Adding GStreamer GL support would apparently
-                          ;; require adding gst-plugins-bad to the inputs,
-                          ;; which might entail a security risk as a result of
-                          ;; the plugins of dubious code quality that are
-                          ;; included.  More investigation is needed.  For
-                          ;; now, we explicitly disable it to prevent an error
-                          ;; at configuration time.
-                          "-DUSE_GSTREAMER_GL=OFF")
+                           (assoc-ref %outputs "out") "/lib"))
        #:make-flags
        ;; Never build with unsupported -j1: https://issues.guix.gnu.org/47964#5
        (list "-j" (number->string (max 2 (parallel-job-count))))