summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-18 17:52:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 22:23:22 +0100
commit7b29927cc947bc66cde79ec9bfb8e20b66c7673f (patch)
tree59744846aab0b8b7b55a47bdf6b50a3466098b08 /gnu
parentc2d41bf423eecd35b38885d320cc1ee3d2872912 (diff)
downloadguix-7b29927cc947bc66cde79ec9bfb8e20b66c7673f.tar.gz
gnu: Add go-github-com-otiai10-mint.
* gnu/packages/golang-check.scm (go-github-com-otiai10-mint): New variable.

Change-Id: I2b203256756bf9dbeb838e2b289f4ffb9c902404
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 00ea185cbc..be282ee3e9 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -697,6 +697,31 @@ Gomega matcher library.")
 framework.")
     (license license:expat)))
 
+(define-public go-github-com-otiai10-mint
+  (package
+    (name "go-github-com-otiai10-mint")
+    (version "1.6.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/otiai10/mint")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0g5zhz4znp68427p2a1yvrxbq90y7caagdd7zsb4iygnhdszfm7w"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:go go-1.21
+      #:import-path "github.com/otiai10/mint"))
+    (home-page "https://github.com/otiai10/mint")
+    (synopsis "Minimal assertion for Golang testing framework")
+    (description
+     "Mint (@code{mint.Mint}) is wrapper for @code{*testing.T} blending
+testing type to omit repeated @code{t}.")
+    (license license:expat)))
+
 (define-public go-github-com-pkg-profile
   (package
     (name "go-github-com-pkg-profile")