summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:59 +0200
commit7b5ff0d6c05155a609eade3f35207ee052702eaf (patch)
tree506c690f1c65d1a3ed739a9f042d8c409c19adc4 /gnu
parent67ee23d68f8ad8c772752e9f636f2305669a4faa (diff)
downloadguix-7b5ff0d6c05155a609eade3f35207ee052702eaf.tar.gz
gnu: Add texlive-to-be-determined.
* gnu/packages/tex.scm (texlive-to-be-determined): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a5d2bb25cb..cf7bd4ad7c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98301,6 +98301,29 @@ cross-reference section (and chapter, etc) titles and captions just like
 instead.")
     (license license:public-domain)))
 
+(define-public texlive-to-be-determined
+  (package
+    (name "texlive-to-be-determined")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/to-be-determined/"
+                   "source/latex/to-be-determined/"
+                   "tex/latex/to-be-determined/")
+             (base32
+              "0jvyvcrnz8vv17rjd3mxb25d2ljrlkmmcl8qk3bnr19gpb4a1vcb")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-soul texlive-xcolor))
+    (home-page "https://ctan.org/pkg/to-be-determined")
+    (synopsis "Highlight text passages that need further work")
+    (description
+     "This package provides a single command @code{\\tbd} which highlights the
+pieces of text that need to be rewritten later.  You can hide them all with
+a single package option hide, or just make them disappear entirely with the
+option off.")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar