summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-09 21:19:48 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:19 +0800
commit7bdf4aa3bb89da7929b85eb39ddaa007f2a56ea0 (patch)
treeba3a1a1d25c7f0e92efe585c20d237a45d89fb9f /gnu
parentd9620855de56c090a9a4992f356e7f74ee19af60 (diff)
downloadguix-7bdf4aa3bb89da7929b85eb39ddaa007f2a56ea0.tar.gz
gnu: python-flex: Update to 6.14.1.
* gnu/packages/python-xyz.scm (python-flex): Update to 6.14.1.
[propagated-inputs]: Remove PYTHON-ISO8601.  Add PYTHON-STRICT-RFC3339.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0dd94edf8a..a01507a36a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22702,23 +22702,23 @@ manipulation, or @code{stdout}.")
 (define-public python-flex
   (package
     (name "python-flex")
-    (version "6.10.0")
+    (version "6.14.1")
     (source
      (origin
       (method url-fetch)
       (uri (pypi-uri "flex" version))
       (sha256
        (base32
-        "00pamnwla3khk8nyla7y28dq9jnh69swd7f4jfsl7sn1izs8n8zk"))))
+        "1sr91f5sqywj4040jm3cq4333fp8hbmmr7v6v05a3h0sgyixcbi9"))))
     (build-system python-build-system)
     (propagated-inputs
      (list python-click
-           python-iso8601
            python-jsonpointer
            python-pyyaml
            python-requests
            python-rfc3987
            python-six
+           python-strict-rfc3339
            python-validate-email))
     (home-page "https://github.com/pipermerriam/flex")
     (synopsis "Validates Swagger schemata")