summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-15 21:11:08 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:50 +0000
commit7c49f2f0aa875abdbbac16800ce9df03c21f8fb0 (patch)
tree0664890099dbc37614d06968c9954c04a108544b /gnu
parent2b5733e32da3bbd254e99ecac03cf1fbd536039a (diff)
downloadguix-7c49f2f0aa875abdbbac16800ce9df03c21f8fb0.tar.gz
gnu: Add go-github-com-tinylib-msgp.
* gnu/packages/golang-xyz.scm (go-github-com-tinylib-msgp): New variable.

Change-Id: I901e4f1671a0868b0042d224f26ed74f2f9d3900
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4b30ecac78..50b3d468ce 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -7080,6 +7080,39 @@ readability, or to compact JSON for smaller payloads.")
 document.")
     (license license:expat)))
 
+(define-public go-github-com-tinylib-msgp
+  (package
+    (name "go-github-com-tinylib-msgp")
+    (version "1.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tinylib/msgp")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0mplb420i9cmf40qwsqzd1plln52nl0x0b7nkxffyr0pdh9za79a"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      ;; Tests require alternative Golang compiler
+      ;; <https://github.com/tinygo-org/tinygo>.
+      #:tests? #f
+      #:import-path "github.com/tinylib/msgp"
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'build))))
+    (propagated-inputs
+     (list go-golang-org-x-tools go-github-com-philhofer-fwd))
+    (home-page "http://msgpack.org/")
+    (synopsis "MessagePack Code Generator")
+    (description
+     "This package provides a code generation tool for creating methods to
+serialize and de-serialize Go data structures to and from data interchange
+format - @url{https://en.wikipedia.org/wiki/MessagePack,MessagePack}.")
+    (license license:expat)))
+
 (define-public go-github-com-tklauser-go-sysconf
   (package
     (name "go-github-com-tklauser-go-sysconf")