summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2024-05-08 14:51:37 +0200
committerChristopher Baines <mail@cbaines.net>2024-05-13 09:11:06 +0100
commit7db57257d5b2fc6fe58f0d51686147cfcce7f6b4 (patch)
treec3689543fe1a9fa8fdfea8a1f6a4c8118debd3e9 /gnu
parent43cd76fa580750bb90e775ce40a24258e002ab19 (diff)
downloadguix-7db57257d5b2fc6fe58f0d51686147cfcce7f6b4.tar.gz
gnu: libshumate: Update to 1.2.1.
* gnu/packages/gnome.scm (libshumate): Update to 1.2.1.
[arguments]: Drop `-Dlibsoup3=true` configure flag as it got removed
upstream.  It only supports libsoup3 now.
[native-inputs]: Add gperf.
[propagated-inputs]: Add json-glib and protobuf-c.

Change-Id: Ibe63b6f2060f6684f8f68f44c2221ba9d6ad5a45
Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c8a80bca06..67049bc253 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -43,7 +43,7 @@
 ;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
 ;;; Copyright © 2019 David Wilson <david@daviwil.com>
 ;;; Copyright © 2019, 2020 Raghav Gururajan <raghavgururajan@disroot.org>
-;;; Copyright © 2019, 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2019, 2020, 2024 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;; Copyright © 2019-2022 Liliana Marie Prikler <liliana.prikler@gmail.com>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -5048,7 +5048,7 @@ libxml to ease remote use of the RESTful API.")
 (define-public libshumate
   (package
     (name "libshumate")
-    (version "1.0.5")
+    (version "1.2.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -5056,11 +5056,10 @@ libxml to ease remote use of the RESTful API.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0v4m07vxm3m4a2vqkp2wfsc3zsf92fpigc1k8yq49vkpj7gxikx8"))))
+                "04cwakbdr68nw4kh956xhf447fawz8badpyd76hg4ir1gq3yw18i"))))
     (build-system meson-build-system)
     (arguments
-     (list #:configure-flags #~(list "-Dlibsoup3=true")
-           #:phases
+     (list #:phases
            #~(modify-phases %standard-phases
                (replace 'check
                  (lambda* (#:key tests? test-options #:allow-other-keys)
@@ -5080,6 +5079,7 @@ libxml to ease remote use of the RESTful API.")
      (list gi-docgen
            `(,glib "bin")
            gobject-introspection
+           gperf
            pkg-config
            ;; For tests:
            xorg-server-for-tests
@@ -5090,7 +5090,9 @@ libxml to ease remote use of the RESTful API.")
      (list cairo
            glib
            gtk
+           json-glib
            libsoup
+           protobuf-c
            sqlite))
     (home-page "https://wiki.gnome.org/Projects/libshumate")
     (synopsis "GtkWidget C library for displaying maps")