summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-10-03 21:31:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-10-03 22:09:31 +0200
commit805505b6000051e5a940d8f076a556f1ecff40bd (patch)
tree72c143654f65bb4e5a8332b8a2f8ba319b628e86 /gnu
parent7947feb090785b54ad1b4329af5134ca0f4d1b55 (diff)
downloadguix-805505b6000051e5a940d8f076a556f1ecff40bd.tar.gz
gnu: emacs-org-super-agenda: Run tests.
* gnu/packages/emacs-xyz.scm (emacs-org-super-agenda)[arguments]<#:tests?>:
Set to #TRUE.
<#:phases>: Re-instate two previously failing tests, skip a new one.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9aa7042924..f2d65a79fc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22540,7 +22540,7 @@ for defining recurring tasks and easily scheduling them.")
         (base32 "07fv4zgmfc8ppppbr7ylhx89wcw6r6vmz4a6pg0iy4v7sn5pp1wa"))))
     (build-system emacs-build-system)
     (arguments
-     `(#:tests? #f                  ;FIXNE: Tests try to read "~/org/test.org"
+     `(#:tests? #true
        #:test-command '("test/run" "--debug")
        #:phases
        (modify-phases %standard-phases
@@ -22550,10 +22550,9 @@ for defining recurring tasks and easily scheduling them.")
              (emacs-substitute-variables "test/test.el"
                ("org-super-agenda-test-results-file"
                 (string-append (getcwd) "/test/results.el")))
-             ;; The following tests fail (see:
-             ;; https://github.com/alphapapa/org-super-agenda/issues/183).
+             ;; The following tests fail.
              (substitute* "test/test.el"
-               ((".*org-super-agenda-test--:auto-(map|tags).*" all)
+               ((".* org-super-agenda-test--with-retained-sorting .*" all)
                 (string-append all "  (skip-unless nil)\n"))))))))
     (native-inputs
      (list emacs-f util-linux))