summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-17 22:28:56 -0400
committerMark H Weaver <mhw@netris.org>2018-03-17 22:45:59 -0400
commit81f6bf2d50ec18d2ca5fff198e9068402437b699 (patch)
treeb7a8b6a3f41355fa3ffe2f1f8937963ed0876a81 /gnu
parenteed6985fc671e7a6410f5a44a717cd7d386e435a (diff)
downloadguix-81f6bf2d50ec18d2ca5fff198e9068402437b699.tar.gz
gnu: glib: Return #t from all phases.
* gnu/packages/glib.scm (glib)[arguments]: In the 'check' phase, use
'for-each' instead to avoid assuming that 'disable' will return a true value.
Return #t from the 'pre-build' and 'check' phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 67099227d3..4a5dc12a49 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -199,7 +199,8 @@ shared NFS home directories.")
                            "glib/tests/utils.c"
                            "tests/spawn-test.c")
               (("/bin/sh")
-               (string-append (assoc-ref inputs "bash") "/bin/sh")))))
+               (string-append (assoc-ref inputs "bash") "/bin/sh")))
+            #t))
         (add-before 'check 'disable-failing-tests
           (lambda _
             (let ((disable
@@ -263,7 +264,8 @@ shared NFS home directories.")
                      ("gio/tests/gdbus-unix-addresses.c"
                       (;; Requires /etc/machine-id.
                        "/gdbus/x11-autolaunch")))))
-              (and-map (lambda (x) (apply disable x)) failing-tests)))))
+              (for-each (lambda (x) (apply disable x)) failing-tests)
+              #t))))
 
       ;; Note: `--docdir' and `--htmldir' are not honored, so work around it.
       #:configure-flags (list (string-append "--with-html-dir="