summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:35:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:05 +0200
commit8819b6adcb3f705cb88051c9dff9e8b62bf38593 (patch)
tree3c3016a86cfe4ee0a25fa1a30b29f8eb126d6db5 /gnu
parentf98fd73a4da49993e33f438f6718418b890f5577 (diff)
downloadguix-8819b6adcb3f705cb88051c9dff9e8b62bf38593.tar.gz
gnu: Add texlive-shortmathj.
* gnu/packages/tex.scm (texlive-shortmathj): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8316bda94c..26e2c13c3d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -27322,6 +27322,26 @@ around the payoffs, (b) payoff columns of equal width, and (c) payoffs
 vertically centered within the boxes.")
     (license license:lppl)))
 
+(define-public texlive-shortmathj
+  (package
+    (name "texlive-shortmathj")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/shortmathj/"
+                   "tex/latex/shortmathj/")
+             (base32
+              "0rkrskx2fay7h6naa995l46xjj8v3ffdd6kx6fq6fknr091yfp7q")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/shortmathj")
+    (synopsis "Automatically shortify titles of mathematical journals")
+    (description
+     "This small dummy package just contains a simple list of full and short
+journal names as written in AMS standard:
+@url{https://mathscinet.ams.org/msnhtml/serials.pdf}.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-showtags
   (package
     (name "texlive-showtags")