summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-19 10:43:06 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-19 11:07:54 +0100
commit8c6117ee2250f2629bc25fae84a7cfd837250780 (patch)
tree07768d5e2550202e57117a97bcf41b01f47d67fa /gnu
parentbe95bcf0887dc7d90177fda20cab56c6e248dcfa (diff)
downloadguix-8c6117ee2250f2629bc25fae84a7cfd837250780.tar.gz
gnu: Add ghc-pandoc-citeproc-with-pandoc-1.
* gnu/packages/haskell.scm (ghc-pandoc-citeproc-with-pandoc-1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9c59f56139..d00bbea7b5 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6396,6 +6396,19 @@ and also has a mode for converting bibliographic databases a YAML format
 suitable for inclusion in pandoc YAML metadata.")
     (license license:bsd-3)))
 
+(define-public ghc-pandoc-citeproc-with-pandoc-1
+  (let ((for-pandoc-1
+         (package-input-rewriting
+          `((,ghc-aeson        . ,ghc-aeson-for-pandoc-1)
+            (,ghc-yaml         . ,ghc-yaml-for-pandoc-1)
+            (,ghc-texmath      . ,ghc-texmath-for-pandoc-1)
+            (,ghc-pandoc-types . ,ghc-pandoc-types-for-pandoc-1)
+            (,ghc-hslua        . ,ghc-hslua-for-pandoc-1)
+            (,ghc-skylighting  . ,ghc-skylighting-for-pandoc-1)
+            (,ghc-doctemplates . ,ghc-doctemplates-for-pandoc-1)
+            (,ghc-pandoc       . ,ghc-pandoc-1)))))
+    (for-pandoc-1 ghc-pandoc-citeproc)))
+
 (define-public ghc-union-find
   (package
     (name "ghc-union-find")