summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-09-11 12:43:40 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-14 10:51:26 +0200
commit8cc8e584ab664057562ccf419031875127a6a395 (patch)
treeb46d8848127cb92aff96bcb0d4312b512eae51ec /gnu
parent2932591b8aeec89732c8f8faa0d3f8ef900e68d2 (diff)
downloadguix-8cc8e584ab664057562ccf419031875127a6a395.tar.gz
gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
* gnu/packages/ruby.scm (ruby-pandoc-ruby)[native-inputs]: Replace ghc-pandoc
with pandoc.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b181d1dc1f..c562ade153 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1115,7 +1115,7 @@ line of code.")
              #t))
          (add-after 'unpack 'patch-pandoc-path
            (lambda* (#:key inputs #:allow-other-keys)
-             (let ((pandoc (string-append (assoc-ref inputs "ghc-pandoc")
+             (let ((pandoc (string-append (assoc-ref inputs "pandoc")
                                           "/bin/pandoc")))
                (substitute* "lib/pandoc-ruby.rb"
                  (("@@pandoc_path = 'pandoc'")
@@ -1135,7 +1135,7 @@ line of code.")
     (native-inputs
      `(("ruby-mocha" ,ruby-mocha)))
     (inputs
-     `(("ghc-pandoc" ,ghc-pandoc)))
+     `(("pandoc" ,pandoc)))
     (synopsis "Ruby wrapper for Pandoc")
     (description "PandocRuby is a wrapper for Pandoc, a Haskell library with
 command line tools for converting one markup format to another.  Pandoc can