summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2024-05-23 14:23:47 -0700
committerVagrant Cascadian <vagrant@debian.org>2024-05-25 13:18:01 -0700
commit94c8cec99969fe9f65777637fde1f05e1c576a3f (patch)
tree52ae0bcc51d982ad55c8bac1bee023a713af42c0 /gnu
parent888d5268229e59b94c1e2616087bec4ca9d09a66 (diff)
downloadguix-94c8cec99969fe9f65777637fde1f05e1c576a3f.tar.gz
gnu: vcmi: Update to 1.5.1.
* gnu/packages/games.scm (vcmi): Update to 1.5.1.
[#:configure-flags]: Disable use of embedded innoextract.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 03a36a8a6d..73d1ffc008 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11467,7 +11467,7 @@ play; it will look for them at @file{~/.local/share/fheroes2} folder.")
 (define-public vcmi
   (package
     (name "vcmi")
-    (version "1.4.5")
+    (version "1.5.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -11476,11 +11476,11 @@ play; it will look for them at @file{~/.local/share/fheroes2} folder.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1z4vy3drj6dra8rb243pyryr61jnlw3l7yxsxwl9rddv8cdk69lz"))
+                "1s3a23p9k081ccbkhvifx2rhg6rv82fkrsbjh6allmmsa1lhq6fd"))
               (patches (search-patches "vcmi-disable-privacy-breach.patch"))))
     (build-system cmake-build-system)
     (arguments
-     (list #:configure-flags #~(list "-DFORCE_BUNDLED_FL=OFF")
+     (list #:configure-flags #~(list "-DFORCE_BUNDLED_FL=OFF" "-DENABLE_INNOEXTRACT=OFF")
            ;; Test suites do not seem well supported upstream and are disabled by default.
            ;; Pass -DENABLE_TEST to configure to enable.
            #:tests? #f))