summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-06-19 09:09:36 +0800
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:13 +0200
commit94f9feb0fb99ee201267c509fb04f3c4fcf7b0e9 (patch)
tree9ec9e29f3bf4d1d98823b9feeb9bd03ecca9e0e1 /gnu
parentcd61ae3bf090ac7c951bedaa6972e1b4cc55b979 (diff)
downloadguix-94f9feb0fb99ee201267c509fb04f3c4fcf7b0e9.tar.gz
gnu: cling: Add libxcrypt dependency.
* gnu/packages/llvm.scm (cling)[inputs]: Add libxcrypt.

Change-Id: I240b73ba1bb2fd3e2d7215c6b342aa45830236cf
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/llvm.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index e0ab789321..a8c6e552c7 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -60,6 +60,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages crypto)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages bootstrap)           ;glibc-dynamic-linker
   #:use-module (gnu packages check)               ;python-lit
@@ -2424,7 +2425,7 @@ LLVM bitcode files.")
             (lambda _
               (for-each delete-file (find-files #$output "\\.a$")))))))
     (native-inputs (list python python-lit))
-    (inputs (list clang-cling llvm-cling))
+    (inputs (list clang-cling llvm-cling libxcrypt))
     (home-page "https://root.cern/cling/")
     (synopsis "Interactive C++ interpreter")
     (description "Cling is an interactive C++17 standard compliant