summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-13 23:37:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-19 23:32:32 +0000
commit971b7b01c145535ea3da3cbe16622160e360140d (patch)
tree4377a4c67f8119479f81218b2da45c20ef807d06 /gnu
parentf5de1f96ed46c427b67d78304977884ff7165538 (diff)
downloadguix-971b7b01c145535ea3da3cbe16622160e360140d.tar.gz
gnu: Add go-github-com-golang-jwt-jwt-v4.
* gnu/packages/golang-crypto.scm (go-github-com-golang-jwt-jwt-v4): New variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: If96f032f404c4aaf80c7bd8a3e231336a8c6dbfb
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-crypto.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 0dd43e0e03..e7dc939c6f 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -19,6 +19,7 @@
 ;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
 ;;; Copyright © 2023 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -426,6 +427,33 @@ providing bidirectional mapping values to their names, plus enum convenience
 for values.")
     (license license:bsd-3)))
 
+(define-public go-github-com-golang-jwt-jwt-v4
+  (package
+    (name "go-github-com-golang-jwt-jwt-v4")
+    (version "4.5.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/golang-jwt/jwt")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1m7c9lwlmd0lnn0hyby1rb3f4nwn4xcjgca218frj0hi0krqn8kp"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/golang-jwt/jwt/v4"))
+    (home-page "https://github.com/golang-jwt/jwt")
+    (synopsis "Go implementation of JSON Web Tokens")
+    (description
+     "This package provides a Go implementation of
+@url{https://datatracker.ietf.org/doc/html/rfc7519, JSON Web Tokens} and
+supports the parsing and verification as well as the generation and signing of
+JSON Web Tokens.  The currently supported signing algorithms are HMAC SHA,
+RSA, RSA-PSS, and ECDSA, though hooks are present for adding your own.")
+    (license license:expat)))
+
 (define-public go-github-com-gxed-hashland-keccakpg
   (let ((commit "d9f6b97f8db22dd1e090fd0bbbe98f09cc7dd0a8")
         (revision "0"))