summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:58:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:44 +0200
commit9c773363764a90769b56d9b10c3373e4dc1aba99 (patch)
tree1e970dee708e2016066d7f28ee9ec7466db2c12c /gnu
parent7b3291b20b3f43ce21c0c406e1bd07e501c4296c (diff)
downloadguix-9c773363764a90769b56d9b10c3373e4dc1aba99.tar.gz
gnu: Add texlive-staves.
* gnu/packages/tex.scm (texlive-staves): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cf5bb5448f..ad157c1a7f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23802,6 +23802,30 @@ applied and theoretical papers in statistics which are currently lacking in
 the popular @code{amsmath} package.")
     (license license:lppl1.3+)))
 
+(define-public texlive-staves
+  (package
+    (name "texlive-staves")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/staves/"
+                   "fonts/map/dvips/staves/"
+                   "fonts/tfm/public/staves/"
+                   "fonts/type1/public/staves/"
+                   "source/latex/staves/"
+                   "tex/latex/staves/")
+             (base32
+              "1wa4zx4c439q6ahs1fwa55dcxzrx382ksrj0bv1jnck6j3iw2dlc")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/staves")
+    (synopsis "Typeset Icelandic staves and runic letters")
+    (description
+     "This package contains all the necessary tools to typeset the magical
+Icelandic staves plus the runic letters used in Iceland.  Included are a font
+in Adobe Type 1 format and LaTeX support.")
+    (license license:lppl)))
+
 (define-public texlive-steinmetz
   (package
     (name "texlive-steinmetz")