summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-11 16:32:21 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:19 +0800
commit9d87b400a699f5d1ca4a303817549733b73dba1e (patch)
treee502876f53fd95d7dd51de571a8da525324f41a9 /gnu
parent7bdf4aa3bb89da7929b85eb39ddaa007f2a56ea0 (diff)
downloadguix-9d87b400a699f5d1ca4a303817549733b73dba1e.tar.gz
gnu: python-deprecated: Update to 1.2.14.
* gnu/packages/python-xyz.scm (python-deprecated): Update to 1.2.14.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a01507a36a..f42b605421 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6155,7 +6155,7 @@ software version simply.")
 (define-public python-deprecated
   (package
     (name "python-deprecated")
-    (version "1.2.13")
+    (version "1.2.14")
     (source
      (origin
        (method git-fetch)
@@ -6165,14 +6165,8 @@ software version simply.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0v4ys9xr8lski2r98da99spsj6hjlnnqgnhhmyhrm66myiix885c"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda* (#:key tests? #:allow-other-keys)
-                      (when tests?
-                        (invoke "pytest")))))))
+         "0knjsacv0r4gyz6ngjn3ih6352yz05r63ll73y2cg162bzcak48z"))))
+    (build-system pyproject-build-system)
     (propagated-inputs
      (list python-wrapt))
     (native-inputs