summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-16 10:55:21 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:50 +0000
commit9e237a7d1327fef03041beaa831e4003ba090804 (patch)
tree3a14d2c4d12b973027f79c19353efa70a2ed82f7 /gnu
parent45f74470378daca81d007fc6726053290e2e1ac2 (diff)
downloadguix-9e237a7d1327fef03041beaa831e4003ba090804.tar.gz
gnu: soju: Fix build.
Fix the build as seen in <https://ci.guix.gnu.org/build/5804515/log/raw>.

* gnu/packages/irc.scm (soju): Fix build.
[arguments]: <#:phases>: Add 'fix-embed-files.

Change-Id: I8d1bddc335ab838127111f70dbc64528aa3dc4ff
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/irc.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 51bd43869e..e75432673e 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -1160,6 +1160,24 @@ what.")
       #:import-path "codeberg.org/emersion/soju"
       #:phases
       #~(modify-phases %standard-phases
+          ;; TODO: Implement it in go-build-system.
+          ;;
+          ;; This happens due to Golang can't determine the valid directory of
+          ;; the module of embed file which is symlinked during setup
+          ;; environment phase, but easy resolved after coping file from the
+          ;; store to the build directory of the current package, see details
+          ;; in Golang source:
+          ;;
+          ;; - URL: <https://github.com/golang/go/blob/>
+          ;; - commit: 82c14346d89ec0eeca114f9ca0e88516b2cda454
+          ;; - file: src/cmd/go/internal/load/pkg.go#L2059
+          (add-after 'unpack 'fix-embed-files
+            (lambda _
+              (for-each (lambda (file)
+                          (let ((file-store-path (readlink file)))
+                            (delete-file file)
+                            (copy-recursively file-store-path file)))
+                        (find-files "src" ".*(editions_defaults.binpb)$"))))
           (add-after 'unpack 'adjust-makefile
             (lambda* (#:key import-path #:allow-other-keys)
               (with-directory-excursion (string-append "src/" import-path)