summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-02 11:03:42 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-02 11:20:29 -0400
commit9ecc29394ee2ceb1da643dc12f2b18b9adbda706 (patch)
tree79e40f906a75d0a5a65797395dcbd4d7c0ff3535 /gnu
parent673d7501ae415f8960c78889784b85020b849608 (diff)
downloadguix-9ecc29394ee2ceb1da643dc12f2b18b9adbda706.tar.gz
gnu: Add python-casa-formats-io.
* gnu/packages/astronomy.scm (python-casa-formats-io): New variable.

Co-Authored-By: Iliya Tikhonenko <tikhonenko@mpe.mpg.de>
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 4afde96a8c..f6b3e5202d 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1624,6 +1624,37 @@ encompassing software system for the operations and analysis of the ESA satelite
 Herschel.")
     (license license:gpl3+)))
 
+(define-public python-casa-formats-io
+  (package
+    (name "python-casa-formats-io")
+    (version "0.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "casa-formats-io" version))
+              (sha256
+               (base32
+                "07cchih2ws6jf6q1a4xhkv0jk96s3w08kzxx9l1911wzqk0pw9pj"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'build-extensions
+            (lambda _
+              (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+    (native-inputs
+     (list python-pytest python-pytest-cov python-pytest-openfiles))
+    (propagated-inputs
+     (list python-astropy python-click python-dask python-numpy))
+    (home-page "https://casa-formats-io.readthedocs.io/")
+    (synopsis "Dask-based reader for CASA data")
+    (description
+     "The @code{casa-formats-io} package is a small package which implements
+functionality to read data stored in @acronym{CASA, Common Astronomy Software
+Applications} formats (such as @file{.image} datasets).  This implementation
+is independent of and does not use @code{casacore}.")
+    (license license:lgpl2.0)))
+
 (define-public python-ccdproc
   (package
     (name "python-ccdproc")