summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-01-16 17:38:38 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:27 +0200
commit9ed23d9a7c0df593e898a3a7c0bee80c34dbdcf2 (patch)
tree4b2ef39a8944cb5ea42c5e90203a9258e389c604 /gnu
parentafda4d87afba616f5add11b8d08fc74061e30c1b (diff)
downloadguix-9ed23d9a7c0df593e898a3a7c0bee80c34dbdcf2.tar.gz
gnu: evolution-data-server: Use C.UTF-8 locale in test.
* gnu/packages/gnome.scm (evolution-data-server): Use C.UTF-8 locale in test.

Change-Id: I8e35a9c96cc89bcd19d8e00472c2ccadf2bd5875
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5f1a268aaa..f129be8540 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8268,6 +8268,10 @@ Microsoft Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
               (delete-file-recursively "tests/book-migration")
               (substitute* "tests/CMakeLists.txt"
                 (("add_subdirectory\\(book-migration\\)") ""))))
+          (add-after 'unpack 'patch-locale-in-test
+            (lambda _
+              (substitute* "tests/libebook/client/test-book-client-custom-summary.c"
+                (("en_US\\.UTF-8") "C.UTF-8"))))
           (add-after 'unpack 'patch-paths
             (lambda _
               (substitute* '("tests/test-server-utils/e-test-server-utils.c"