summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:56 +0200
commit9ee703d892e6f9dc99321f10047807e6a0a76fad (patch)
treedbcfc3e5aeaf08afe6dd0c72feb877b85b73b6e5 /gnu
parent1b24f8a91da6682683a1f45043e6efe7c1e6e3d2 (diff)
downloadguix-9ee703d892e6f9dc99321f10047807e6a0a76fad.tar.gz
gnu: Add texlive-thumby.
* gnu/packages/tex.scm (texlive-thumby): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 357c649c6f..b3c68a3d66 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98146,6 +98146,29 @@ reference guides, anthologies, etc.), where a quick and easy way to find (for
 example) a chapter is needed.")
     (license license:lppl1.3+)))
 
+(define-public texlive-thumby
+  (package
+    (name "texlive-thumby")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/thumby/" "tex/latex/thumby/")
+             (base32
+              "138ddfn5ha4lbmf66snwvvrvjx0anfgcb9gpv2slbybm0lb9gb6k")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/thumby")
+    (synopsis "Create thumb indexes for printed books")
+    (description
+     "The package can generate thumb indexes for your document.  It features
+printing thumb indexes on one- or two-sided pages, along with background- and
+foreground-color selection and full LaTeX styling of the chapter numbers in
+the thumb indexes.  The height of each thumb index is automatically chosen
+based on the number of chapters in your document, while the width is chosen by
+the user.  The package is designed to work with the @code{memoir} class, and
+also requires PerlTeX and TikZ.")
+    (license license:gpl3)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar