summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-28 14:54:09 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-02-28 14:54:09 +0100
commita052882c03f905218ff13fed8c851bdb80dd7a8f (patch)
treee76316efb2903f4b3e7faf296f34956eada92df1 /gnu
parentf29f80c194d0c534a92354b2bc19022a9b70ecf8 (diff)
downloadguix-a052882c03f905218ff13fed8c851bdb80dd7a8f.tar.gz
gnu: Add emacs-project-tab-groups.
* gnu/packages/emacs-xyz.scm (emacs-project-tab-groups): New variable.

Change-Id: If190fa02490ce952512ea3abf3dc4b3f990778a5
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6414c98fa9..1a6606252c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1378,6 +1378,30 @@ some utility functions, and commands using that infrastructure.")
 its mode line.")
       (license license:gpl3+))))
 
+(define-public emacs-project-tab-groups
+  (let ((commit "2658405d5f3c539fbd9ccf95297a016a2c91816a")
+        (revision "1"))
+    (package
+      (name "emacs-project-tab-groups")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/fritzgrabo/project-tab-groups.git")
+               (commit commit)))
+         (sha256
+          (base32 "1zg9kxyjz942ib9lii0in67hwqil2xlz78vjm1qqypw3zaivhh7p"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/fritzgrabo/project-tab-groups")
+      (synopsis "Support a \"one tab group per project\" workflow")
+      (description "This package provides a global minor mode that enhances the
+Emacs built-in @code{project.el} library to support keeping projects isolated
+in named tab groups.  This package automates the steps you’d otherwise need to
+do manually if you wanted to keep the buffers of a project neatly isolated in
+separate, named tab groups.")
+      (license license:gpl3+))))
+
 (define-public emacs-golden-ratio
   (let ((commit "375c9f287dfad68829582c1e0a67d0c18119dab9")
         (revision "0"))