summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-15 10:40:05 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-15 14:07:56 +0200
commita2131c12bec62673bcd9bd51891df862884a1c37 (patch)
tree1737daa132e9d771aa2b0b59c2eb22d0821bd5e6 /gnu
parent16c66d1d6775249d4d4e81a18f2649fe1912d93a (diff)
downloadguix-a2131c12bec62673bcd9bd51891df862884a1c37.tar.gz
gnu: openjdk9: Fix build.
* gnu/packages/java.scm (openjdk9)[arguments]: Pass '-fcommon' to CFLAGS.
  [native-inputs]: Add gcc-9.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 0ac5234443..2a48612a81 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -60,6 +60,7 @@
   #:use-module (gnu packages elf)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages gawk)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages ghostscript) ;lcms
@@ -1961,6 +1962,7 @@ new Date();"))
            (lambda* (#:key inputs outputs #:allow-other-keys)
              ;; TODO: unbundle libpng and lcms
              (invoke "bash" "./configure"
+                     "--with-extra-cflags=-fcommon"
                      (string-append "--with-freetype=" (assoc-ref inputs "freetype"))
                      "--disable-freetype-bundling"
                      "--disable-warnings-as-errors"
@@ -2089,7 +2091,8 @@ new Date();"))
        ("libxt" ,libxt)
        ("libxtst" ,libxtst)))
     (native-inputs
-     `(("icedtea-8" ,icedtea-8)
+     `(("gcc" ,gcc-9) ; FIXME: segmentation faults when using gcc-10.
+       ("icedtea-8" ,icedtea-8)
        ("icedtea-8:jdk" ,icedtea-8 "jdk")
        ;; XXX: The build system fails with newer versions of GNU Make.
        ("make@4.2" ,gnu-make-4.2)