summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-12-05 14:15:45 +0900
committerLudovic Courtès <ludo@gnu.org>2019-01-17 14:04:22 +0100
commita8307a178bdcb74d0798e76953cd5c9ea4b53f0b (patch)
tree6ee6fa58f91a7519216bc83839db10bee064ded3 /gnu
parent7e3e6d721dd084d9245acb7ab867e1496ce2e887 (diff)
downloadguix-a8307a178bdcb74d0798e76953cd5c9ea4b53f0b.tar.gz
gnu: Add guile-parted.
* gnu/packages/guile.scm (guile-parted): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 7564767972..8d14571895 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -46,6 +46,7 @@
   #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages dbm)
+  #:use-module (gnu packages disk)
   #:use-module (gnu packages ed)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages gawk)
@@ -2382,4 +2383,42 @@ Scheme by using Guile’s foreign function interface.")
 microblogging service.")
     (license license:gpl3+)))
 
+;; There has not been any release yet.
+(define-public guile-parted
+  (let ((commit "ea3f1a1f6844775fc59d3078d2a09c62ffb341b8")
+        (revision "0"))
+    (package
+      (name "guile-parted")
+      (version (string-append "0-" revision "." (string-take commit 9)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://gitlab.com/mothacehe/guile-parted")
+                      (commit commit)))
+                (file-name (string-append name "-" version "-checkout"))
+                (sha256
+                 (base32
+                  "1q7425gpjlwi2wvhzq7kw046yyx7v6j6jyzkd1cr861iz34mjwiq"))))
+      (build-system gnu-build-system)
+      (arguments
+       '(#:make-flags
+         '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+      (inputs
+       `(("guile" ,guile-2.2)
+         ("parted" ,parted)))
+      (propagated-inputs
+       `(("guile-bytestructures" ,guile-bytestructures)))
+      (native-inputs
+       `(("autoconf" ,autoconf)
+         ("automake" ,automake)
+         ("pkg-config" ,pkg-config)))
+      (synopsis "Guile bindings to GNU Parted")
+      (description
+       "This package provides bindings for GNU Parted library, a C library
+allowing disk partition tables creation and manipulation. The bindings are
+written in pure Scheme by using Guile's foreign function interface.")
+      (home-page "https://gitlab.com/mothacehe/guile-parted")
+      (license license:gpl3+))))
+
 ;;; guile.scm ends here
+