summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-29 10:08:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-29 10:43:36 +0200
commitaa85b99a884e688de683f8c546c93b1e31b1ea30 (patch)
tree73a5f522cebb384798148c08f2bafb08bf072c4a /gnu
parentd45a3fec65a5626b3db3615333fa1b9f0d2e41c4 (diff)
downloadguix-aa85b99a884e688de683f8c546c93b1e31b1ea30.tar.gz
gnu: emacs-context-transient: Update to 1.0.1.
* gnu/packages/emacs-xyz.scm (emacs-context-transient): Update to 1.0.1.

Change-Id: Ie77367c0f5d65218d0b2d5a9fef28cd7e4156a91
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm36
1 files changed, 17 insertions, 19 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 445d65bc09..24120750b7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -39647,27 +39647,25 @@ by leveraging @code{emacs-consult} APIs.")
     (license license:expat)))
 
 (define-public emacs-context-transient
-  (let ((commit "16b8e16645ebcdc44d2777ba16ac85e1d3ee468b")
-        (revision "0"))
-    (package
-      (name "emacs-context-transient")
-      (version (git-version "1.0.0" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/licht1stein/context-transient.el")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "147yv3ih9il6a4k2cw1kcqgdpls83jf7aspjf8km650ry0apycc6"))))
-      (build-system emacs-build-system)
-      (home-page "https://github.com/licht1stein/context-transient.el")
-      (synopsis "Context specific transients")
-      (description "This package makes it easy to define and call
+  (package
+    (name "emacs-context-transient")
+    (version "1.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/licht1stein/context-transient.el")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1slj9js7c4cggdidr7miri9gf9xm7ij4hmd7y99km7bqmg57837l"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/licht1stein/context-transient.el")
+    (synopsis "Context specific transients")
+    (description "This package makes it easy to define and call
 context-specific @code{emacs-transient} menus for current project, git repo,
 buffer or any other condition.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-purs-mode
   ;; XXX: Upstream set no tag nor any Version keyword.  Using 0 as the base