summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 17:21:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:00 +0200
commitab124adbab2b762243288289a66d76af92069e8c (patch)
tree254913b74aa19ccd571979bc5e5bdb559a19bb7e /gnu
parent298f75b7ab2a91a8b569d47a316fc2df4e586271 (diff)
downloadguix-ab124adbab2b762243288289a66d76af92069e8c.tar.gz
gnu: rust-spki: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-spki-0.7, rust-spki-0.6,
rust-spki-0.5, rust-spki-0.4): Move from here ...
* gnu/packages/crates-crypto.scm: ... to here.

Change-Id: Ib158054b467de3ae9098a0f65a0bf66c6f331bc2
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-crypto.scm83
-rw-r--r--gnu/packages/crates-io.scm83
2 files changed, 83 insertions, 83 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 9b4f3e2c04..a42b49b3b3 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -4400,6 +4400,89 @@ for additional details.")
         ("rust-syn" ,rust-syn-1)
         ("rust-synstructure" ,rust-synstructure-0.12))))))
 
+(define-public rust-spki-0.7
+  (package
+    (name "rust-spki")
+    (version "0.7.3")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "spki" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "17fj8k5fmx4w9mp27l970clrh5qa7r5sjdvbsln987xhb34dc7nr"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-arbitrary" ,rust-arbitrary-1)
+        ("rust-base64ct" ,rust-base64ct-1)
+        ("rust-der" ,rust-der-0.7)
+        ("rust-sha2" ,rust-sha2-0.10))
+       #:cargo-development-inputs
+       (("rust-hex-literal" ,rust-hex-literal-0.4)
+        ("rust-tempfile" ,rust-tempfile-3))))
+    (home-page "https://github.com/RustCrypto/formats/tree/master/spki")
+    (synopsis
+     "X.509 Subject Public Key Info (RFC5280) describing public keys")
+    (description
+     "This package provides X.509 Subject Public Key Info (RFC5280)
+describing public keys as well as their associated AlgorithmIdentifiers (i.e.
+OIDs)")
+    (license (list license:asl2.0 license:expat))))
+
+(define-public rust-spki-0.6
+  (package
+    (inherit rust-spki-0.7)
+    (name "rust-spki")
+    (version "0.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "spki" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0ar1ldkl7svp8l3gfw2hyiiph7n2nqynjnjgdv1pscvsmjxh5kv7"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-base64ct" ,rust-base64ct-1)
+        ("rust-der" ,rust-der-0.6)
+        ("rust-sha2" ,rust-sha2-0.10))
+       #:cargo-development-inputs
+       (("rust-hex-literal" ,rust-hex-literal-0.3)
+        ("rust-tempfile" ,rust-tempfile-3))))))
+
+(define-public rust-spki-0.5
+  (package
+    (inherit rust-spki-0.7)
+    (name "rust-spki")
+    (version "0.5.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "spki" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "09qaddm4kw01xm9638910bm4yqnshzh2p38lvc3kxkvc5b01ml24"))))
+    (arguments
+     `(#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1)
+                       ("rust-der" ,rust-der-0.5)
+                       ("rust-sha2" ,rust-sha2-0.9))
+       #:cargo-development-inputs (("rust-hex-literal" ,rust-hex-literal-0.3))))))
+
+(define-public rust-spki-0.4
+  (package
+    (inherit rust-spki-0.7)
+    (name "rust-spki")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "spki" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0ckgkcg6db5y94dqhmyikgn8yrsah6pyf4j197hv1c51bp0s00aw"))))
+    (arguments `(#:skip-build? #t #:cargo-inputs (("rust-der" ,rust-der-0.4))))))
+
 (define-public rust-subtle-2
   (package
     (name "rust-subtle")
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cb9a708d2a..ea67892bd1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -65406,89 +65406,6 @@ and spirv-std-macros.")
 SPIR-V.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-spki-0.7
-  (package
-    (name "rust-spki")
-    (version "0.7.3")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "spki" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "17fj8k5fmx4w9mp27l970clrh5qa7r5sjdvbsln987xhb34dc7nr"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-arbitrary" ,rust-arbitrary-1)
-        ("rust-base64ct" ,rust-base64ct-1)
-        ("rust-der" ,rust-der-0.7)
-        ("rust-sha2" ,rust-sha2-0.10))
-       #:cargo-development-inputs
-       (("rust-hex-literal" ,rust-hex-literal-0.4)
-        ("rust-tempfile" ,rust-tempfile-3))))
-    (home-page "https://github.com/RustCrypto/formats/tree/master/spki")
-    (synopsis
-     "X.509 Subject Public Key Info (RFC5280) describing public keys")
-    (description
-     "This package provides X.509 Subject Public Key Info (RFC5280)
-describing public keys as well as their associated AlgorithmIdentifiers (i.e.
-OIDs)")
-    (license (list license:asl2.0 license:expat))))
-
-(define-public rust-spki-0.6
-  (package
-    (inherit rust-spki-0.7)
-    (name "rust-spki")
-    (version "0.6.0")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "spki" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0ar1ldkl7svp8l3gfw2hyiiph7n2nqynjnjgdv1pscvsmjxh5kv7"))))
-    (arguments
-     `(#:cargo-inputs
-       (("rust-base64ct" ,rust-base64ct-1)
-        ("rust-der" ,rust-der-0.6)
-        ("rust-sha2" ,rust-sha2-0.10))
-       #:cargo-development-inputs
-       (("rust-hex-literal" ,rust-hex-literal-0.3)
-        ("rust-tempfile" ,rust-tempfile-3))))))
-
-(define-public rust-spki-0.5
-  (package
-    (inherit rust-spki-0.7)
-    (name "rust-spki")
-    (version "0.5.4")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "spki" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "09qaddm4kw01xm9638910bm4yqnshzh2p38lvc3kxkvc5b01ml24"))))
-    (arguments
-     `(#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1)
-                       ("rust-der" ,rust-der-0.5)
-                       ("rust-sha2" ,rust-sha2-0.9))
-       #:cargo-development-inputs (("rust-hex-literal" ,rust-hex-literal-0.3))))))
-
-(define-public rust-spki-0.4
-  (package
-    (inherit rust-spki-0.7)
-    (name "rust-spki")
-    (version "0.4.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "spki" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0ckgkcg6db5y94dqhmyikgn8yrsah6pyf4j197hv1c51bp0s00aw"))))
-    (arguments `(#:skip-build? #t #:cargo-inputs (("rust-der" ,rust-der-0.4))))))
-
 (define-public rust-spmc-0.3
   (package
     (name "rust-spmc")