summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-28 00:17:13 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:25 +0200
commitac9798bf4b38189888bc738b90e314d64c7c29b5 (patch)
tree93cc251c55b1d1ac93ae12ae41ae7716ef5bc10e /gnu
parent309ca0e77291f8a3589ecd7fcc7d417778928ca1 (diff)
downloadguix-ac9798bf4b38189888bc738b90e314d64c7c29b5.tar.gz
gnu: Add texlive-tex4ht-bin.
* gnu/packages/tex.scm (texlive-tex4ht-bin): New variable.
(texlive-tex4ht)[arguments]<#:link-scripts>: Remove as those are now provided by
TEXLIVE-TEX4HT-BIN.
[inputs]: Remove PERL.
[propagated-inputs]: Add TEXLIVE-TEX4HT-BIN.

Change-Id: Ib9a677d61a86419db4f5d60401566d340fbcf80d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm60
1 files changed, 47 insertions, 13 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1b7bfe5d22..5cf49673c4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -43719,19 +43719,7 @@ for use in planning a class.")
               "1svmivc272xj9fzy5p055lp7g9vcqs75jp4x54682yrq0qizv03c")))
     (outputs '("out" "doc"))
     (build-system texlive-build-system)
-    (arguments
-     (list #:link-scripts
-           #~(list "ht.sh"
-                   "htcontext.sh"
-                   "htlatex.sh"
-                   "htmex.sh"
-                   "httex.sh"
-                   "httexi.sh"
-                   "htxelatex.sh"
-                   "htxetex.sh"
-                   "mk4ht.pl"
-                   "xhlatex.sh")))
-    (inputs (list perl))
+    (propagated-inputs (list texlive-tex4ht-bin))
     (home-page "https://ctan.org/pkg/tex4ht")
     (synopsis "Convert (La)TeX to HTML/XML")
     (description
@@ -43746,6 +43734,52 @@ TeX4ht to approach the robustness characteristic of restricted-syntax systems
 such as @code{gellmu}.")
     (license license:lppl)))
 
+(define-public texlive-tex4ht-bin
+  (package
+    (inherit texlive-bin)
+    (name "texlive-tex4ht-bin")
+    (source
+     (origin
+       (inherit texlive-source)
+       (modules '((guix build utils)
+                  (ice-9 ftw)))
+       (snippet
+        #~(let ((delete-other-directories
+                 (lambda (root dirs)
+                   (with-directory-excursion root
+                     (for-each
+                      delete-file-recursively
+                      (scandir "."
+                               (lambda (file)
+                                 (and (not (member file (append '("." "..") dirs)))
+                                      (eq? 'directory (stat:type (stat file)))))))))))
+            (delete-other-directories "libs" '())
+            (delete-other-directories "utils" '())
+            (delete-other-directories "texk" '("tex4htk"))))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments texlive-bin)
+       ((#:configure-flags flags)
+        #~(cons "--enable-tex4htk" (delete "--enable-web2c" #$flags)))
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            (replace 'check
+              (lambda* (#:key tests? #:allow-other-keys)
+                (when tests?
+                  (with-directory-excursion "texk/tex4htk"
+                    (invoke "make" "check")))))
+            (replace 'install
+              (lambda _
+                (with-directory-excursion "texk/tex4htk"
+                  (invoke "make" "install"))))))))
+    (native-inputs (list pkg-config))
+    (inputs (list perl texlive-libkpathsea))
+    (propagated-inputs '())
+    (home-page (package-home-page texlive-tex4ht))
+    (synopsis "Binaries for @code{texlive-tex4ht}")
+    (description
+     "This package provides the binaries for @code{texlive-tex4ht}.")
+    (license (package-license texlive-tex4ht))))
+
 (define-public texlive-tex4ebook
   (package
     (name "texlive-tex4ebook")